Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-3177

mapreduce tar layout does not conform new layout

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 0.23.0, 0.24.0
    • Fix Version/s: 0.23.1
    • Component/s: build
    • Labels:
      None

      Description

      The tar generated by MR does not follow the layout of common & hdfs, instead, it uses a arbitrary layout which is also different from the old legacy layout (there is a modules/ directory with all the MR jars)

        Issue Links

          Activity

          Alejandro Abdelnur created issue -
          Mahadev konar added a comment -

          Alejandro,
          Is there a list of jira's regarding distribution/build that we need to keep track to backport to 0.23 once everything stabilizes on trunk? It might make be easier to create a uber task and mark these jiras as sub tasks to keep track of what jira's are needed for mavenization/dist fixes in 0.23?

          Alejandro Abdelnur added a comment -

          I'll open a JIRA to keep track of the Maven related JIRAs to backport to 0.23. Doing subtasks is not feasible because subtasks cannot span across projects.

          Mahadev konar added a comment -

          Sounds good!

          Alejandro Abdelnur made changes -
          Field Original Value New Value
          Assignee Mahadev konar [ mahadev ]
          Arun C Murthy made changes -
          Fix Version/s 0.23.1 [ 12318883 ]
          Fix Version/s 0.23.0 [ 12315570 ]
          Fix Version/s 0.24.0 [ 12317654 ]
          Mahadev konar made changes -
          Link This issue duplicates MAPREDUCE-3366 [ MAPREDUCE-3366 ]
          Mahadev konar added a comment -

          Duplicate of MAPREDUCE-3366. Looks like Eric has a patch on that jira.

          Mahadev konar added a comment -

          Duplicate of MAPREDUCE-3366.

          Mahadev konar made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Mahadev konar
              Reporter:
              Alejandro Abdelnur
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development