Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2931

CLONE - LocalJobRunner should support parallel mapper execution

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.0
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      The LocalJobRunner currently supports only a single execution thread. Given the prevalence of multi-core CPUs, it makes sense to allow users to run multiple tasks in parallel for improved performance on small (local-only) jobs.

      It is necessary to patch back MAPREDUCE-1367 into Hadoop 0.20.X version. Also, MapReduce-434 should be submitted together.

        Issue Links

          Activity

          Matt Foley added a comment -

          Moved to 1.2.0 upon release of 1.1.0.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12564000/MAPREDUCE-1367-branch1.patch
          against trunk revision .

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3219//console

          This message is automatically generated.

          Tom White added a comment -

          This would be good to have. Sandy, if you haven't already can you do a unit test run to check that there are no regressions please.

          Sandy Ryza added a comment -

          Yeah, I did already and everything looked ok.

          Tom White added a comment -

          I just committed this. Thanks, Sandy.

          Arun C Murthy added a comment -

          Sandy Ryza / Tom White - Looks like Hive is badly broken on branch-1 due to this (see MAPREDUCE-5166), should we revert this now and re-commit after the fix? Thanks.

          Matt Foley added a comment -

          added 1.2.0 to fixVersion, per CHANGES.txt

          Matt Foley added a comment -

          Closed upon release of Hadoop 1.2.0.


            People

            • Assignee:
              Sandy Ryza
              Reporter:
              Forest Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development