Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Last nightly build failed to publish javadoc because the javadoc build failed:

      javadoc:
      [mkdir] Created dir: /grid/0/hudson/hudson-slave/workspace/Hadoop-Mapreduce-22-branch/trunk/build/docs/api
      [javadoc] Generating Javadoc
      [javadoc] Javadoc execution
      [javadoc] 1 error
      [javadoc] javadoc: error - Cannot find doclet class org.apache.hadoop.classification.tools.ExcludePrivateAnnotationsStandardDoclet

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #643 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk/643/)

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-22-branch #33 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-22-branch/33/)

          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #609 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/609/)
          MAPREDUCE-2315. javadoc is failing in nightly build. Contributed by Todd Lipcon

          Todd Lipcon added a comment -

          Committed to trunk and branch, will kick off another build. Thanks Arun

          Arun C Murthy added a comment -

          +1, seems reasonable.

          Todd Lipcon added a comment -

          This patch fixes the issue for me (applies against both 22 and trunk)

          Todd Lipcon added a comment -

          Aha, I see the issue. The doclet tag in build.xml refers to hadoop-common-$

          {version}

          rather than hadoop-common-$

          {hadoop-common.version}

          . So, on nightly, where the version includes a timestamp, it doesn't put the right common jar on the docletpath and fails.

          Todd Lipcon added a comment -

          Looks like same issue as MAPREDUCE-1947 (which is about test-patch)

          Todd Lipcon added a comment -

          Unfortunately I can't seem to reproduce this running "ant javadoc" from my local build... anyone got any ideas?


            People

            • Assignee:
              Todd Lipcon
              Reporter:
              Todd Lipcon
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development