Some comments on the patch:
(1) Why are the variable names and method names start with the word "expected" ? Since these are the values that are already seen(and not the values expected), please remove the word "expected" everywhere.
(2) You missed making changes to HadoopLogAnalyzer.incorporateCounters().
(3) You missed making changes to LoggedTaskAttempt.deepCompare().
(4) Empty comments as javadoc are seen for the new methods. Please add some comments there.
(5) Better to change the new(and may be existing ones also ?) data members of LoggedTaskAttempt private and use setters and getters everywhere because even if I change getExpectedVirtualMemorySize() to return expectedVirtualMemorySizeInBytes-2, testcase is not failing.