Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-2090

Clover build doesn't generate per-test coverage

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.1, 0.22.0
    • Fix Version/s: 0.21.1
    • Component/s: build, test
    • Labels:
      None
    • Release Note:
      This fix requires that test coverage is running under Clover 3.0+

      Description

      Because of the way the structure of Hadoop's builds is done Clover can't properly detect test classes among the sources. As the result clover reports are incomplete and do not provide viral per-test coverage info.

      1. MAPREDUCE-2090.patch
        0.5 kB
        Konstantin Boudnik
      2. MAPREDUCE-2090.patch
        0.5 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          9d 9h 39m 1 Konstantin Boudnik 04/Oct/10 04:53
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #523 (See https://hudson.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/523/)

          Konstantin Boudnik made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Release Note This fix requires that test coverage is running under Clover 3.0+
          Fix Version/s 0.21.1 [ 12315272 ]
          Resolution Fixed [ 1 ]
          Konstantin Boudnik added a comment -

          The fix is exactly the same as for HADOOP-6971. Thus, no separate review seems needed. I have ran the test with Clover on and see that the problem is gone.

          Konstantin Boudnik made changes -
          Attachment MAPREDUCE-2090.patch [ 12455518 ]
          Konstantin Boudnik made changes -
          Attachment MAPREDUCE-2090.patch [ 12455517 ]
          Konstantin Boudnik made changes -
          Summary CLONE -Clover build doesn't generate per-test coverage Clover build doesn't generate per-test coverage
          Konstantin Boudnik made changes -
          Project Hadoop Common [ 12310240 ] Hadoop Map/Reduce [ 12310941 ]
          Key HADOOP-6973 MAPREDUCE-2090
          Affects Version/s 0.21.1 [ 12315272 ]
          Affects Version/s 0.22.0 [ 12314184 ]
          Affects Version/s 0.22.0 [ 12314296 ]
          Affects Version/s 0.20.3 [ 12314812 ]
          Affects Version/s 0.21.1 [ 12315270 ]
          Component/s build [ 12312909 ]
          Component/s test [ 12312904 ]
          Component/s test [ 12311440 ]
          Component/s build [ 12311543 ]
          Konstantin Boudnik made changes -
          Field Original Value New Value
          Link This issue is a clone of HADOOP-6971 [ HADOOP-6971 ]
          Konstantin Boudnik created issue -

            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development