Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1622

Include slf4j dependencies in binary tarball

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      After MAPREDUCE-1556 and HADOOP-6486, starting *Trackers from a binary tarball produces the following warning:

      SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      2010-03-18 01:11:32.988::INFO:  Logging to STDERR via org.mortbay.log.StdErrLog
      2010-03-18 01:11:33.056::INFO:  jetty-6.1.14
      
      1. M1622-0.patch
        0.7 kB
        Chris Douglas

        Activity

        Chris Douglas added a comment -

        This resolves the missing dependency by adding the slf4j deps to common instead of test

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12439609/M1622-0.patch
        against trunk revision 926449.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/53/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/53/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/53/console

        This message is automatically generated.

        Chris Douglas added a comment -

        Core failure is caused by HADOOP-6645, but this should not affect unit tests

        Doug Cutting added a comment -

        +1 patch looks good. It's hard to write a test for this, since the test classpath is fine, it's the non-test classpath that has a problem.

        Chris Douglas added a comment -

        I committed this.


          People

          • Assignee:
            Chris Douglas
            Reporter:
            Chris Douglas
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development