Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1448

[Mumak] mumak.sh does not honor --config option.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0, 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When --config is specified, mumak.sh should put the customized conf directory in the classpath.

      1. mapred-1448.patch
        1.0 kB
        Hong Tang
      2. mapred-1448-2.patch
        1 kB
        Hong Tang

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Patch Available Patch Available Open Open
        1d 2h 49m 1 Hong Tang 04/Feb/10 10:48
        Open Open Patch Available Patch Available
        5m 54s 2 Hong Tang 04/Feb/10 10:51
        Patch Available Patch Available Resolved Resolved
        4d 14h 52m 1 Chris Douglas 09/Feb/10 01:43
        Resolved Resolved Closed Closed
        196d 19h 36m 1 Tom White 24/Aug/10 22:20
        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #232 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk/232/)

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #230 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/230/)
        . Respect --config option in Mumak script. Contributed by Hong Tang

        Chris Douglas made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Fix Version/s 0.22.0 [ 12314184 ]
        Resolution Fixed [ 1 ]
        Chris Douglas added a comment -

        +1

        I committed this. Thanks, Hong!

        Hong Tang added a comment -

        The failed test is irrelevant to this patch, and is likely caused by a partially downloaded or corrupted jar file.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12434804/mapred-1448-2.patch
        against trunk revision 906228.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/301/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/301/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/301/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/301/console

        This message is automatically generated.

        Hong Tang made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hong Tang added a comment -

        The failed tests are likely caused by HADOOP-6538. Retry hudson.

        Hong Tang made changes -
        Attachment mapred-1448-2.patch [ 12434804 ]
        Hong Tang made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12434651/mapred-1448.patch
        against trunk revision 905875.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/430/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/430/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/430/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/430/console

        This message is automatically generated.

        Hong Tang made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Affects Version/s 0.21.0 [ 12314045 ]
        Affects Version/s 0.22.0 [ 12314184 ]
        Assignee Hong Tang [ hong.tang ]
        Fix Version/s 0.21.0 [ 12314045 ]
        Fix Version/s 0.22.0 [ 12314184 ]
        Hong Tang made changes -
        Field Original Value New Value
        Attachment mapred-1448.patch [ 12434651 ]
        Hong Tang added a comment -

        Manually tested with non-default location of conf directory. No tests included because the bug is in the script.

        Hong Tang created issue -

          People

          • Assignee:
            Hong Tang
            Reporter:
            Hong Tang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development