Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Release Note:
      Fixed a bug in the testcase TestTTResourceReporting.

      Description

      TestTTResourceReporting failing in trunk.

      The most specific issue from the logs seems to be : Error executing shell command org.apache.hadoop.util.Shell$ExitCodeException: kill: No such process

      Link :
      http://hudson.zones.apache.org/hudson/view/Hadoop/job/Hadoop-Mapreduce-trunk/217/

      Attaching output in a file.

      1. MAPREDUCE-1420-v1.patch
        3 kB
        Chris Douglas
      2. MAPREDUCE-1420-v1.patch
        3 kB
        Scott Chen
      3. output.rtf
        138 kB
        Iyappan Srinivasan

        Activity

        Scott Chen added a comment -

        Thanks for the report. I think I am the last person touched this code. I will investigate this and fix it.

        Scott Chen added a comment -

        It seems that the problem is the reported CPU frequency doesn't match the expected one.
        This is because the CPU frequency in /proc/cpuinfo can actually change on some environment
        See http://lwn.net/Articles/162548/
        The test works on my dev box but not hudson this time.

        The patch remove CPU frequency from the static value checking.
        It will still be verified in the dynamic value checking.

        dhruba borthakur added a comment -

        +1, change looks good.

        Iyappan Srinivasan added a comment -

        The output in a readable format

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12431641/output.rtf
        against trunk revision 909793.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 21 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/320/console

        This message is automatically generated.

        Chris Douglas added a comment -

        Reattaching Scott's patch for Hudson

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12435770/MAPREDUCE-1420-v1.patch
        against trunk revision 909799.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/321/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/321/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/321/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/321/console

        This message is automatically generated.

        Scott Chen added a comment -

        Thanks, Chris.
        Got a -1 because of no tests. Since this is a fix for the unit test, it should be OK if there's no new unit test added.

        Vinod Kumar Vavilapalli added a comment -

        Resubmitting to Hudson. Will commit it if Hudson signs OK..

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12435770/MAPREDUCE-1420-v1.patch
        against trunk revision 920250.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/510/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/510/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/510/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/510/console

        This message is automatically generated.

        Scott Chen added a comment -

        Thanks for the help, Vinod. It is strange that there are many failed tests.
        The patch only changes one unit tests. There is no dependency between this one and those unit tests.
        I will investigate this.

        Vinod Kumar Vavilapalli added a comment -

        The failures are the usual suspects - missing common classes similar to failures in MAPREDUCE-890, MAPREDUCE-927 etc., a wierd scenario which i could never explain, and HADOOP-6528. Resubmitting to Hudson again with the hope of a test-pass this time.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12435770/MAPREDUCE-1420-v1.patch
        against trunk revision 921069.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/514/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/514/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/514/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/514/console

        This message is automatically generated.

        Scott Chen added a comment -

        Test succeed after resubmitted

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12435770/MAPREDUCE-1420-v1.patch
        against trunk revision 921230.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/29/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/29/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/29/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/29/console

        This message is automatically generated.

        Scott Chen added a comment -

        @Vinod, The patch has passed the test twice. I think it is ready to go

        Chris Douglas added a comment -

        +1

        I committed this. Thanks, Scott!

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #288 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/288/)
        . Fix TestTTResourceReporting failure. Contributed by Scott Chen

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #264 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk/264/)
        . Fix TestTTResourceReporting failure. Contributed by Scott Chen


          People

          • Assignee:
            Scott Chen
            Reporter:
            Iyappan Srinivasan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development