Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1359

TypedBytes TestIO doesn't mkdir its test dir first

    Details

    • Type: Test Test
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.21.0, 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: contrib/streaming
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestIO fails when run alone since it doesn't mkdir its test directory in the setUp function. This JIRA should fix it and update the tests to use junit 4 style.

        Activity

        Anatoli Fomenko added a comment -

        Please review the suggested patch.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12429718/MAPREDUCE-1359.1.patch
        against trunk revision 897076.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/365/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/365/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/365/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/365/console

        This message is automatically generated.

        Konstantin Boudnik added a comment -

        Test failures seem to be unrelated and have been caused by some build issues. All contrib tests and TestIO in particular are fine. Patch looks good to me. I'll wait a couple of days and if there's no other opinions I'll commit it.

        Anatoli Fomenko added a comment -

        Please review the submitted patch. Thanks.

        Konstantin Boudnik added a comment -

        I've just committed this to 0.21 and 0.22. Congratulations on your first committed contribution, Anatoli. Thanks!

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #212 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk/212/)
        . TypedBytes TestIO doesn't mkdir its test dir first. Contributed by Anatoli Fomenko
        . TypedBytes TestIO doesn't mkdir its test dir first. Contributed by Anatoli Fomenko

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #225 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/225/)


          People

          • Assignee:
            Anatoli Fomenko
            Reporter:
            Todd Lipcon
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development