Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1282

eclipse plugin cannot be compiled in in windows

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: contrib/eclipse-plugin
    • Labels:
      None
    • Environment:

      Windows, Cygwin

      Description

      bash-3.2$ ant -Declipse.home=/cygdrive/d/eclipse-java-ganymede-win32/
      Buildfile: build.xml
      ...
      BUILD FAILED
      d:\@sze\hadoop\latest\src\contrib\build-contrib.xml:112: d:\cygdrive\d\eclipse-java-ganymede-win32\plugins not found.
      

      It seems that build-contrib.xml messed up the path.

        Issue Links

          Activity

          Tsz Wo Nicholas Sze created issue -
          Hide
          Chris Douglas added a comment -

          According to HADOOP-3744, there are some issues with ganymede, but this looks like a separate issue. Does it work with ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib ? It doesn't look like there are any recent changes to contrib build files that would change the way this path is handled...

          Show
          Chris Douglas added a comment - According to HADOOP-3744 , there are some issues with ganymede, but this looks like a separate issue. Does it work with ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib ? It doesn't look like there are any recent changes to contrib build files that would change the way this path is handled...
          Hide
          Tsz Wo Nicholas Sze added a comment -

          > Does it work with ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib ?
          Got some differnt errors:

          bash-3.2$ ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib
          Buildfile: build.xml
          
          ...
          
          init-contrib:
          
          compile:
               [echo] contrib: eclipse-plugin
              [javac] Compiling 45 source files to d:\@sze\hadoop\latest\build\contrib\eclipse-plugin\classes
              [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:35: cannot find symbol
              [javac] symbol  : class JavaApplicationLaunchShortcut
              [javac] location: package org.eclipse.jdt.internal.debug.ui.launcher
              [javac] import org.eclipse.jdt.internal.debug.ui.launcher.JavaApplicationLaunchShortcut;
              [javac]                                                  ^
              [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:49: cannot find symbol
              [javac] symbol: class JavaApplicationLaunchShortcut
              [javac]     JavaApplicationLaunchShortcut {
              [javac]     ^
              [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:66: cannot find symbol
              [javac] symbol  : variable super
              [javac] location: class org.apache.hadoop.eclipse.launch.HadoopApplicationLaunchShortcut
              [javac]         super.findLaunchConfiguration(type, configType);
              [javac]         ^
              [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:60: method does not override or implement a method from a supertype
              [javac]   @Override
              [javac]   ^
              [javac] Note: Some input files use or override a deprecated API.
              [javac] Note: Recompile with -Xlint:deprecation for details.
              [javac] Note: Some input files use unchecked or unsafe operations.
              [javac] Note: Recompile with -Xlint:unchecked for details.
              [javac] 4 errors
          
          BUILD FAILED
          d:\@sze\hadoop\latest\build.xml:416: The following error occurred while executing this line:
          d:\@sze\hadoop\latest\src\contrib\build.xml:30: The following error occurred while executing this line:
          d:\@sze\hadoop\latest\src\contrib\build-contrib.xml:112: Compile failed; see the compiler error output for details.
          
          Total time: 15 seconds
          bash-3.2$ 
          
          Show
          Tsz Wo Nicholas Sze added a comment - > Does it work with ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib ? Got some differnt errors: bash-3.2$ ant -Declipse.home='d:\eclipse-java-ganymede-win32' compile-contrib Buildfile: build.xml ... init-contrib: compile: [echo] contrib: eclipse-plugin [javac] Compiling 45 source files to d:\@sze\hadoop\latest\build\contrib\eclipse-plugin\classes [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:35: cannot find symbol [javac] symbol : class JavaApplicationLaunchShortcut [javac] location: package org.eclipse.jdt.internal.debug.ui.launcher [javac] import org.eclipse.jdt.internal.debug.ui.launcher.JavaApplicationLaunchShortcut; [javac] ^ [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:49: cannot find symbol [javac] symbol: class JavaApplicationLaunchShortcut [javac] JavaApplicationLaunchShortcut { [javac] ^ [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:66: cannot find symbol [javac] symbol : variable super [javac] location: class org.apache.hadoop.eclipse.launch.HadoopApplicationLaunchShortcut [javac] super.findLaunchConfiguration(type, configType); [javac] ^ [javac] d:\@sze\hadoop\latest\src\contrib\eclipse-plugin\src\java\org\apache\hadoop\eclipse\launch\HadoopApplicationLaunchShortcut.java:60: method does not override or implement a method from a supertype [javac] @Override [javac] ^ [javac] Note: Some input files use or override a deprecated API. [javac] Note: Recompile with -Xlint:deprecation for details. [javac] Note: Some input files use unchecked or unsafe operations. [javac] Note: Recompile with -Xlint:unchecked for details. [javac] 4 errors BUILD FAILED d:\@sze\hadoop\latest\build.xml:416: The following error occurred while executing this line: d:\@sze\hadoop\latest\src\contrib\build.xml:30: The following error occurred while executing this line: d:\@sze\hadoop\latest\src\contrib\build-contrib.xml:112: Compile failed; see the compiler error output for details. Total time: 15 seconds bash-3.2$
          Tsz Wo Nicholas Sze made changes -
          Field Original Value New Value
          Link This issue relates to HADOOP-3744 [ HADOOP-3744 ]
          Chris Douglas made changes -
          Project Hadoop Common [ 12310240 ] Hadoop Map/Reduce [ 12310941 ]
          Key HADOOP-4310 MAPREDUCE-1282
          Component/s contrib/eclipse-plugin [ 12313175 ]
          Component/s contrib/eclipse-plugin [ 12312095 ]
          Hide
          Eli Collins added a comment -

          This is a dupe of MAPREDUCE-1280 - these compilation issues are due to deprecated classes, not windows.

          Show
          Eli Collins added a comment - This is a dupe of MAPREDUCE-1280 - these compilation issues are due to deprecated classes, not windows.
          Eli Collins made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development