Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.20.1
    • Fix Version/s: 0.20.2
    • Component/s: None
    • Labels:
      None

      Description

      HADOOP-5759 is already fixed as a part of MAPREDUCE-364 in hadoop 0.21.
      This will fix the same problem with CombineFileInputFormat for hadoop 0.20.

      1. MAPREDUCE-1112.1.patch
        109 kB
        Zheng Shao
      2. MAPREDUCE-1112.2.patch
        9 kB
        Zheng Shao

        Issue Links

          Activity

          Zheng Shao added a comment -

          This is fixed in hadoop 0.21 as part of MAPREDUCE-364

          Zheng Shao added a comment -

          Ported part of MAPREDUCE-364 to Hadoop 0.20.

          Zheng Shao added a comment -

          Removed unnecessary changes to examples.

          Zheng Shao added a comment -

          MAPREDUCE-1112.1.patch changed the CombineFileInputFormat to implement InputFormat instead of FileInputFormat.
          It is not backward compatible.

          I will make CombineFileInputFormat inherits from FileInputFormat as before but just fix the bug of host name/rack name.

          Zheng Shao added a comment -

          MAPREDUCE-1112.2.patch: This patch only contains what is needed for CombineFileInputFormat to work with hadoop 0.20.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12422469/MAPREDUCE-1112.2.patch
          against trunk revision 825469.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          -1 patch. The patch command could not apply the patch.

          Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/179/console

          This message is automatically generated.

          Zheng Shao added a comment -

          Hadoop QA is trying to apply it to trunk... But this is for branch 0.20.

          Zheng Shao added a comment -

          BTW, just to speed up the review, this patch is a subset of changes in MAPREDUCE-364, which is already committed to trunk.

          Todd Lipcon added a comment -

          Hi Zheng. This looks like the same patch as in HADOOP-5759 (not sure how MAPREDUCE-364 plays in here). So is this JIRA really just that we should apply the HADOOP-5759 patch to branch-20?

          Is there a unit test which can verify this by actually running a job using CombineFileInputFormat?

          Zheng Shao added a comment -

          My bad. Yes it's the same as HADOOP-5759, except a file name change.

          I will commit HADOOP-5759 to branch-0.20, and mark this one as duplicate.

          Zheng Shao added a comment -

          Duplicate of HADOOP-5759.


            People

            • Assignee:
              Zheng Shao
              Reporter:
              Zheng Shao
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development