Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1022

Trunk tests fail because of test-failure in Vertica

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0, 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None

      Description

      ant test fails with

          [javac] /home/vinodkv/Workspace/eclipse-workspace/hadoop-mapreduce/src/contrib/vertica/src/test/org/apache/hadoop/vertica/TestVertica.java:43: cannot find symbol
          [javac] symbol  : class JobContextImpl
          [javac] location: package org.apache.hadoop.mapreduce
          [javac] import org.apache.hadoop.mapreduce.JobContextImpl;
          [javac]                                   ^
      
      1. MAPREDUCE-1022.20090922.txt
        0.8 kB
        Vinod Kumar Vavilapalli

        Activity

        Vinod Kumar Vavilapalli added a comment -

        As Ravi pointed offline, this is due to the wrong package name for JobContextImpl used in TestVertical.java. Changing it to org.apache.hadoop.mapreduce.task.JobContextImpl does the trick. Attaching a patch.

        Ravi Gummadi added a comment -

        Why is JobContextImpl under mapreduce/task/ directory ? Should it be under mapreduce/ ?

        Konstantin Boudnik added a comment -

        Sorry if I'm missing some context here, but I'm wondering how this class get into a different package and why that hasn't been caught before?

        Vinod Kumar Vavilapalli added a comment -

        Sorry if I'm missing some context here, but I'm wondering how this class get into a different package and why that hasn't been caught before?

        This was caused by MAPREDUCE-775. The contributor made it Patch Available and Hudson blessed it on Sep 13 and the patch got committed on Sep 19 without it going through Hudson again. Mean while, MAPREDUCE-777 went in breaking this patch. Ideally MAPREDUCE-775 should have been run through Hudson again, but this case it wasn't done (perhaps due to the Feature Freeze date pressure, perhaps).

        Konstantin Boudnik added a comment -

        So, in other words contributors (nor committers reviewing the patch) bother to whole test cycle on their own and Hudson became our very last line of defense?

        It seems to me that while Hudson can only do so much we are likely to be getting broken commits unless we'll raise the bar of the quality of the submissions.

        Arun C Murthy added a comment -

        This new classes were introduced by MAPREDUCE-954, but I ran 'ant jar-test' which didn't seem to catch it - not sure why. I'm going to commit this.

        Arun C Murthy added a comment -

        but I ran 'ant jar-test' which didn't seem to catch it

        Sorry, that was 'ant tar' - and the problem was MAPREDUCE-1031...

        Arun C Murthy added a comment -

        I just committed this. Thanks, Vinod!

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #61 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/61/)
        . Fix compilation of vertica testcases. Contributed by Vinod Kumar Vavilapalli.


          People

          • Assignee:
            Vinod Kumar Vavilapalli
            Reporter:
            Vinod Kumar Vavilapalli
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development