Uploaded image for project: 'Maven Ant Tasks (RETIRED)'
  1. Maven Ant Tasks (RETIRED)
  2. MANTTASKS-175

Dependencies ignoring user defined repo location and reverting to central

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: dependencies task
    • Labels:
      None
    • Environment:
      Windows XP

      Description

      I have a very simple dependencies declaration:

      <artifact:dependencies filesetId="dependency.fileset" settingsFile="${app.mavenSettings}">
          <dependency groupId="com.mycompany.infrastructure" artifactId="artifact" version="2.0.0"/>
      </artifact:dependencies>

      I have 2 mirrors set up:

      <mirrors>
      	<mirror>
      		<id>all_mirror</id>
      		<name>Nexus All</name>
      		<url>http://maven-proxy.mycompany.com/content/groups/all</url>
      		<mirrorOf>*,!central</mirrorOf>
      	</mirror>
      	<mirror>
      		<id>central_mirror</id>
      		<name>Nexus Releases</name>
      		<url>http://maven-proxy.mycompany.com/content/groups/public</url>
      		<mirrorOf>central</mirrorOf>
      	</mirror>
      </mirrors>

      When I instruct Maven to retreive the dependency it gets the pom file correctly, which contains a 2nd dependency, which is retrieved. These are both retrieved from the correct repo. But the 2nd pom then defines another dependency. But this 3rd dependency is searched for at central, where it doesnt exist (all artifacts are internal libraries).

      Downloading: com/mycompany/myartifact1/version1/artifact1-version1.pom from repository central_mirror at http://mycompany.com/content/groups/public
      Transferring 4K from central_mirror
      Downloading: com/mycompany/myartifact2/version2/artifact2-version2.pom from repository central_mirror at http://mycompany.com/content/groups/public
      Transferring 24K from central_mirror
      Downloading: com/mycompany/myartifact3/version3/artifact3-version3.pom from repository central at http://repo1.maven.org/maven2
      Error transferring file: Connection timed out: connect
      

      So the first 2 are resolved and d/loaded fine, but the 3rd suddenly reverts to looking in central, when it is present and correct in the central_mirror repo.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                paulwilliams Paul WIlliams
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: