Uploaded image for project: 'Mahout'
  1. Mahout
  2. MAHOUT-1499

Build error: org.eclipse.paho:mqtt-client

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 0.9
    • Fix Version/s: 0.10.0
    • Component/s: build
    • Labels:

      Description

      Using Maven, I'm unable to build the 0.9.0 distribution I just downloaded. I attempt like so:

      mvn -U -Pyarn -Dhadoop.version=2.2.0 -Dyarn.version=2.2.0 -DskipTests package
      

      The Maven error is:

      [ERROR] Failed to execute goal on project spark-examples_2.10: Could not resolve dependencies for project org.apache.spark:spark-examples_2.10:jar:0.9.0-incubating: Could not find artifact org.eclipse.paho:mqtt-client:jar:0.4.0 in nexus
      

      My Maven version is 3.2.1, running on Java 1.7.0, using Scala 2.10.4.
      Is there an additional Maven repository I should add or something?

      If I go into the pom.xml and comment out the external/mqtt and examples modules, the build succeeds. I'm fine without the MQTT stuff, but I would really like to get the examples working because I haven't played with Spark before.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              kenahoo Ken Williams
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: