Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v2.0
    • Component/s: All Modules
    • Labels:
      None

      Description

      PostgreSQL 10 is in beta now and will be released in Fall 2017, so will be in good time frame for support in MADlib 2.0

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user edespino opened a pull request:

          https://github.com/apache/madlib/pull/182

          MADLIB-1154. PostgreSQL 10 (beta 4) support.

          *Postgres 10 header file movement*

          Move some things from builtins.h to new header files
          https://github.com/postgres/postgres/commit/f21a563d25dbae153937aec062161184189478b8

          o format_procedure has moved into utils/regproc.h (from
          utils/builtins.h)

          o Functions for the variable-length built-in types moved into
          utils/varlena.h (from utils/builtins.h)

          *libpq/md5.h has moved to common/md5.h*

          Postgres 10 change
          Move code shared between libpq and backend from backend/libpq/ to common/.
          https://github.com/postgres/postgres/commit/ec136d19b21791c845b1deeff43df137add0639e

          *Convert sketch to Version 1 Calling Conventions.*

          *Update "is_less_than_pg90" to accommodate "10beta" version.*

          *PlEASE NOTE* The Postgres Beta string is non-standard and I have been able to account for it in "is_less_than_pg90". There are other checks when installing madlib and running install-check that fail and it fallbacks to using the newest supported version. Here is the message received:

          > Could not parse version string reported by PostgreSQL. Will default to newest supported version of PostgreSQL (10.0).

          For reference, this is the "select_version()" output for Postgres 10 beta4:

          ```
          psql -c "select version()"
          version
          ----------------------------------------------------------------------------------------------------------------
          PostgreSQL 10beta4 on x86_64-apple-darwin16.7.0, compiled by Apple LLVM version 8.1.0 (clang-802.0.42), 64-bit
          (1 row)

          ```
          I have successfully built and run install/install-check against PostgreSQL 9.6 and 10beta4.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/edespino/madlib MADLIB-1154

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/madlib/pull/182.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #182


          commit 12f6c2047c3bf20e48fdb128a4fc158eaf14c47c
          Author: Ed Espino <eespino@pivotal.io>
          Date: 2017-08-17T23:01:22Z

          MADLIB-1154. PostgreSQL 10 (beta 4) support.

          • Postgres 10 header file movement

          Move some things from builtins.h to new header files
          https://github.com/postgres/postgres/commit/f21a563d25dbae153937aec062161184189478b8

          o format_procedure has moved into utils/regproc.h (from
          utils/builtins.h)

          o Functions for the variable-length built-in types moved into
          utils/varlena.h (from utils/builtins.h)

          • libpq/md5.h has moved to common/md5.h

          Postgres 10 change
          Move code shared between libpq and backend from backend/libpq/ to common/.
          https://github.com/postgres/postgres/commit/ec136d19b21791c845b1deeff43df137add0639e

          • Convert sketch to Version 1 Calling Conventions.
          • Update "is_less_than_pg90" to accommodate "10beta" version.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit commented on the issue:

          https://github.com/apache/madlib/pull/182

          Refer to this link for build results (access rights to CI server needed):
          https://builds.apache.org/job/madlib-pr-build/215/

          githubbot ASF GitHub Bot added a comment -

          Github user edespino commented on the issue:

          https://github.com/apache/madlib/pull/182

          Jenkins ok to test

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit commented on the issue:

          https://github.com/apache/madlib/pull/182

          Refer to this link for build results (access rights to CI server needed):
          https://builds.apache.org/job/madlib-pr-build/219/

          githubbot ASF GitHub Bot added a comment -

          Github user jingyimei commented on the issue:

          https://github.com/apache/madlib/pull/182

          I tested it against postgres10beta4 on a local centos6 docker container, and I got the following error when installing MADlib:
          [postgres@31e9a35af8a7 build]$ src/bin/madpack -p postgres -c postgres/postgres@localhost:5432/test install
          Traceback (most recent call last):
          File "/build/src/bin/../madpack/madpack.py", line 1580, in <module>
          main(sys.argv[1:])
          File "/build/src/bin/../madpack/madpack.py", line 1169, in main
          for versionStr in supportedVersions])))
          ValueError: max() arg is an empty sequence

          Here is the postgres version info:
          test=# select version();
          version
          ------------------------------------------------------------------------------------------------------------
          PostgreSQL 10beta4 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-18), 64-bit
          (1 row)

          Still looking into the root cause of it.

          githubbot ASF GitHub Bot added a comment -

          Github user edespino commented on the issue:

          https://github.com/apache/madlib/pull/182

          Interesting you received that type of error with Postgres missing the "--with-python" build flag. I wonder if MADlib is capable of determining if python support is available. If it isn't, there is no sense in installing MADlib.

          githubbot ASF GitHub Bot added a comment -

          Github user njayaram2 commented on the issue:

          https://github.com/apache/madlib/pull/182

          Will go ahead and merge this since @jingyimei has approved.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/madlib/pull/182


            People

            • Assignee:
              espino Ed Espino
              Reporter:
              fmcquillan Frank McQuillan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development