Lucene - Core
  1. Lucene - Core
  2. LUCENE-4108

Add replaceTaxonomy to DirectoryTaxonomyWriter

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-ALPHA, 6.0
    • Component/s: modules/facet
    • Labels:
      None
    • Lucene Fields:
      New, Patch Available

      Description

      I'd like to add the option to replace a taxonomy with another one, "live" on DirectoryTaxoWriter. Similar to how one can do so on IndexWriter, by calling deleteAll() and addIndexes(), it is valuable to be able to do so on DirTW as well.

      That way, if you need to replace a search index and taxonomy index "live", you will be able to, given this new API.

        Activity

        Shai Erera added a comment -

        Patch against trunk. Adds replaceTaxonomy to DirTaxoWriter as well as relevant test.

        All tests pass, I will commit this tomorrow.

        Shai Erera added a comment -

        Committed revision 1346784 to trunk, now porting to 4x.

        Shai Erera added a comment -

        Committed revision 1346793 to 4x.

        Since this is not a bug fix, I will not port to 3.6.1, unless someone requests it.

        Robert Muir added a comment -

        CHANGES.txt is mangled

        Shai Erera added a comment -

        I committed a fix for that – moved the relevant entries to the 4.0.0 section. Hope it's ok now.


          People

          • Assignee:
            Shai Erera
            Reporter:
            Shai Erera
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development