Uploaded image for project: 'Lucene - Core'
  1. Lucene - Core
  2. LUCENE-3526

preflex codec returns wrong terms if you use an empty field name

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-ALPHA
    • Fix Version/s: 4.0-ALPHA
    • Component/s: None
    • Labels:
      None
    • Lucene Fields:
      New

      Description

      spinoff from LUCENE-3473.

      I have a standalone test for this... the termsenum is returning a bogus extra empty-term (I assume it has no postings, i didnt try).

      This causes the checkindex test in LUCENE-3473 to fail, because there are 4 terms instead of 3.

        Attachments

        1. LUCENE-3526_test.patch
          1 kB
          Robert Muir
        2. LUCENE-3526_test.patch
          2 kB
          Robert Muir
        3. LUCENE-3526_test.patch
          6 kB
          Robert Muir
        4. LUCENE-3526_test.patch
          6 kB
          Robert Muir
        5. LUCENE-3526.patch
          7 kB
          Robert Muir
        6. LUCENE-3526.patch
          8 kB
          Michael McCandless

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rcmuir Robert Muir
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: