I think users see the name optimize and feel they must do this, because who wants a suboptimal system? but this probably just results in wasted time and resources.
maybe rename to collapseSegments or something?
- relates to
SOLR-3141 Warn in logs at Optimize (was: Deprecate OPTIMIZE command in Solr)