Lucene - Core
  1. Lucene - Core
  2. LUCENE-2253

Lucene 3.0 - Deprecated QueryParser Constructor in Demo Code [new QueryParser( "contents", analyzer)]

    Details

    • Lucene Fields:
      New

      Description

      Found this issue when following the getting started tutorial with Lucene 3.0. It appears the QueryParser constructor was deprecated

      The new code in results.jsp should be changed from:

      new QueryParser("contents", analyzer)

      to:

      new QueryParser(Version.LUCENE_CURRENT, "contents", analyzer)

      http://www.locklevels.com

        Activity

        Lock Levels created issue -
        Robert Muir added a comment -

        duplicate of LUCENE-2132, fixed there in both trunk and 3.0 branch.

        Robert Muir made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Simon Willnauer added a comment -

        Changed issue to Task / Trivial.

        Thanks for reporting this.

        Simon Willnauer made changes -
        Issue Type Bug [ 1 ] Task [ 3 ]
        Priority Major [ 3 ] Trivial [ 5 ]
        Component/s Examples [ 12310231 ]
        Mark Thomas made changes -
        Workflow jira [ 12498275 ] Default workflow, editable Closed status [ 12563438 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12563438 ] jira [ 12584778 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Lock Levels
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development