Commons Logging
  1. Commons Logging
  2. LOGGING-72

LogFactoryImpl.guessConfig overrides configuration

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.3
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      problem occurred in version 1.0.2-release.

      When using another Log implementation than log4j (e.g. SimpleLog), but with
      log4j available, LogFactoryImpl.guessConfig creates
      org.apache.commons.logging.impl.Log4jFactory as a proxy factory anyway, and in
      this way unwantedly overrides your custom setting.

        Activity

        Craig McClanahan added a comment -
            • COM-449 has been marked as a duplicate of this bug. ***
        Craig McClanahan added a comment -

        The configuration override was actually a side effect of Log4JLogger, rather
        than Log4jFactory, and that has been removed. In addition, per discussion on
        COMMONS-DEV, the Log4jFactory class has been deprecated, and use of a proxy
        instance of the class removed from the implementation of LogFactoryImpl. Fixed
        in nightly build 20030402.


          People

          • Assignee:
            Unassigned
            Reporter:
            Felix Janssen
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development