Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.0.3
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: All

    • Bugzilla Id:
      13118

      Description

      [javac]
      .......\logging\src\java\org\apache\commons\logging\impl\Log4JCategoryLog.java:
      137: warning:
      setPriority(org.apache.log4j.Priority) in org.apache.log4j.Category
      has been deprecated

        Activity

        seapwc@halcyon.com Paul Campbell added a comment -
            • COM-188 has been marked as a duplicate of this bug. ***
        craig.mcclanahan@sun.com Craig McClanahan added a comment -

        Fixed in nightly build 20021123.

        This deprecation warning occurs because Log4J has deprecated the entire Category
        class, replacing it by o.a.l.Logger. What really needed to happen here is that
        we create a new Log4JLogger implementation (based on Log4JCategoryLog, which was
        deprecated), and start using that for the Log4J Log implementation class.


          People

          • Assignee:
            Unassigned
            Reporter:
            seapwc@halcyon.com Paul Campbell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development