Commons Logging
  1. Commons Logging
  2. LOGGING-55

[all] exclude package.html files from the distribution jars

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1.0
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

      Description

      Hi,

      could you please remove the package.html files from the generated jars? We are
      having problems with commons-logging and commons-beanutils, but this probably
      affects a lot more projects...

      For instance, if I have commons-logging.jar and commons-beanutils.jar in my
      classpath, I receive the following warnings from the JDK1.5 javadoc tool. This
      is caused by the package.html files present in these jars.

      [javadoc] javadoc: warning - Multiple sources of package comments found for
      package "org"
      [javadoc] javadoc: warning - Multiple sources of package comments found for
      package "org.apache"
      [javadoc] javadoc: warning - Multiple sources of package comments found for
      package "org.apache.commons"

      thanks,
      Maarten

        Activity

        Simon Kitching added a comment -

        The ant build.xml file has been updated to exclude the package.html files.
        Thanks for reporting this.


          People

          • Assignee:
            Unassigned
            Reporter:
            Maarten Coene
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development