Uploaded image for project: 'Commons Logging'
  1. Commons Logging
  2. LOGGING-36

[logging] Wrong version for dependency avalon-framework in project.xml

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Nightly Builds
    • Fix Version/s: 1.0.4
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

    • Bugzilla Id:
      25941

      Description

      When I tried to build commons-logging (pulled from CVS) I needed to find the
      right version of the avalon-framework. The project.xml file says to use version 4.0.

      When I ran the unit-tests they wanted the class
      org.apache.avalon.framework.logger.ConsoleLogger, and that is not included in
      4.0. After some digging in the CVS I found the class in question in version 4.1.3.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dennisl@apache.org Dennis Lundberg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: