Commons Logging
  1. Commons Logging
  2. LOGGING-14

[logging] LogConfigurationException double wrapped

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.4
    • Fix Version/s: 1.1.0
    • Labels:
      None
    • Environment:

      Operating System: Windows 2000
      Platform: PC

      Description

      LogFactoryImpl.getLogConstructor() double-wraps when it throws
      LogConfigurationException. In other words, when it throws
      LogConfigurationException, it wraps that exception in another
      LogConfigurationException. In fact, the full message is:

      org.apache.commons.logging.LogConfigurationException:
      org.apache.commons.logging.LogConfigurationException:
      java.lang.NullPointerException (Caused by java.lang.NullPointerException)
      (Caused by org.apache.commons.logging.LogConfigurationException:
      java.lang.NullPointerException (Caused by java.lang.NullPointerException))

      Feel free to track that mess down, but this report is just for this one instance
      of wrapping.

      The wrapping occurs on line 397. You can fix it either by ensuring the "throw
      new" calls are outside the "catch Throwable", or you can add an extra catch:

      catch (LogConfigurationException ex)

      { throw ex; }

      catch (Throwable t)

      { throw new LogConfigurationException(t); }

        Activity

        Dennis Lundberg made changes -
        Fix Version/s 1.1.0 [ 12311848 ]
        Henri Yandell made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Henri Yandell made changes -
        Affects Version/s 1.0.4 [ 12311713 ]
        Henri Yandell made changes -
        Project Commons [ 12310458 ] Commons Logging [ 12310484 ]
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Component/s Logging [ 12311124 ]
        Key COM-2114 LOGGING-14
        Affects Version/s 1.0.4 [ 12311678 ]
        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 35112 12342266
        Simon Kitching added a comment -

        Thanks for reporting this Bill. The LogFactoryImpl class is getting some
        significant modifications right at this moment. Brian Stansberry's proposed
        patch actually fixes this as a part of some other changes. I'm marking this bug
        entry "fixed" although the patch isn't yet committed because it is expected that
        it very soon will be.

        Bill Zwicky created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Bill Zwicky
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development