Log4cxx
  1. Log4cxx
  2. LOGCXX-4

initialization not working on many OS's

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.7
    • Fix Version/s: 0.10.0
    • Component/s: Configurator
    • Labels:
      None
    • Environment:
      AIX 5.1 xlC 6.0, Linux w/ GCC, Win XP, probably others

      Description

      log4cxx initialization does not work properly. Running examples gives:
      'you have tried to set a null value to root'

      Presumably, this problem is caused by problems in initializing static data in level.cpp and logmanager.cpp

        Activity

        Curt Arnold added a comment -

        Commit msg: http://nagoya.apache.org/eyebrowse/ReadMsg?listName=log4cxx-dev@logging.apache.org&msgNo=314

        Summary: http://nagoya.apache.org/eyebrowse/ReadMsg?listName=log4cxx-user@logging.apache.org&msgNo=457

        The crashes were due to dependency on non-local static variables called during configuration which can occur during static initialization. Since the order that initialization occurs is not defined bad things happen, typically log4cxx::Level::DEBUG or a string literal used in parsing the configuration file was still null.


          People

          • Assignee:
            Curt Arnold
            Reporter:
            joe zendle
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development