Log4cxx
  1. Log4cxx
  2. LOGCXX-27

Appender threshold cannot be set in configuration files

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.7
    • Fix Version/s: 0.10.0
    • Component/s: Configurator
    • Labels:
      None
    • Environment:
      Linux, but affects all platforms.

      Description

      The threshold of an appender cannot be configured using
      the Property- or DOMConfigurator, because AppenderSkeleton
      lacks a properly implemented setOption method.

      For example:

      log4j.properties: log4j.appender.faultAppender.Threshold=WARN
      log4j.xml: <param name="Threshold" value="WARN" />

        Issue Links

          Activity

          Martin Landers created issue -
          Martin Landers added a comment -

          Sorry, seems the input form got me there... Duplicate of LOGCXX-28.

          Curt Arnold made changes -
          Field Original Value New Value
          Link This issue duplicates LOGCXX-28 [ LOGCXX-28 ]
          Curt Arnold added a comment -

          Duplicate of resolved bug LOGCXX-12.

          Curt Arnold made changes -
          Fix Version/s 0.9.8 [ 10782 ]
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Alan Cabrera made changes -
          Link This issue duplicates LOGCXX-28 [ LOGCXX-28 ]
          Alan Cabrera made changes -
          Link This issue duplicates LOGCXX-28 [ LOGCXX-28 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1d 22h 19m 1 Curt Arnold 22/Oct/04 14:28

            People

            • Assignee:
              Michaël CATANZARITI
              Reporter:
              Martin Landers
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development