Uploaded image for project: 'Log4net'
  1. Log4net
  2. LOG4NET-632

UDPAppender does not work when configured by file under .net core

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.0.8
    • Fix Version/s: None
    • Component/s: Appenders
    • Labels:
      None
    • Environment:

      Description

      I have run across an issue with the UDP appender where it acts differently depending upon how the system is configured.

       

      Attached is 2 sample programs (one zip file). One targets .net 4.7.2 and the other targets .net core 2.1. Each program has 2 methods in it called testByFile and testProgrammatically. Also included in the zip is the log4net.config file I used with both programs.

       

      I would expect all 4 methods to behave the same since my programmatic configuration matches the file. When configured by file, the core application does not log to the UDP appender. I have verified this by looking at wireshark while the program is running. The UDP Appender works as expected for the other 3 configuration methods.

       

      Obviously the work around is to configure log4net programmatically. My question is why does this one case fail though? I would expect to be able to go to .net core and still use a config file.

       

      Any help you can provide would be greatly appreciated.

      Keith Henderson 

        Attachments

        1. SampleApplication.zip
          354 kB
          Keith Henderson

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              khenderson Keith Henderson
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: