Uploaded image for project: 'Log4net'
  1. Log4net
  2. LOG4NET-466

"LockRecursionException: A read lock may not be acquired with the write lock held in this mode." exception

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.13
    • Fix Version/s: 2.0.8
    • Component/s: Core
    • Labels:
      None
    • Environment:
      Windows 7 x64 / .NET 4.5.2

      Description

      I'm getting this exception when trying to call ILog.Error() method (the logger used is RollingFileAppender):

      log4net:ERROR Exception while logging
      System.Threading.LockRecursionException: A read lock may not be acquired with the write lock held in this mode.
      at System.Threading.ReaderWriterLockSlim.TryEnterReadLockCore(TimeoutTracker timeout)
      at System.Threading.ReaderWriterLockSlim.TryEnterReadLock(TimeoutTracker timeout)
      at System.Threading.ReaderWriterLockSlim.EnterReadLock()
      at log4net.Util.ReaderWriterLock.AcquireReaderLock()
      at log4net.Repository.Hierarchy.Logger.CallAppenders(LoggingEvent loggingEvent)
      at log4net.Repository.Hierarchy.Logger.ForcedLog(Type callerStackBoundaryDeclaringType, Level level, Object message, Exception exception)
      at log4net.Repository.Hierarchy.Logger.Log(Type callerStackBoundaryDeclaringType, Level level, Object message, Exception exception)

      Any ideas why it might be happening?

        Issue Links

          Activity

          bodewig Stefan Bodewig added a comment -

          This may very well stem from the same root cause that created LOG4NET-443.

          bodewig Stefan Bodewig added a comment -

          does it still happen with 1.2.14 or 1.2.15? LOG4NET-443 has been fixed in 1.2.14.


            People

            • Assignee:
              Unassigned
              Reporter:
              fandrei Andrei Faber
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development