Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.14, 1.3.0
    • Component/s: None
    • Labels:
      None

      Description

      This is github pull request 6: https://github.com/apache/log4net/pull/6

      This correction enables opening a new file without causing all the AcquireLock blocking with AbandonedMutexException caused by incorrect state on ReleaseLock, namely m_mutexClosed.

      The bug was found using InterProcessLockwith RollingFileAppender with date pattern on file name, at midnight the new file is opened and all logging becomes blocked at InterProcessLock.AcquireLock on m_mutex.WaitOne.

        Activity

        bodewig Stefan Bodewig added a comment -

        svn revision 1544744.


          People

          • Assignee:
            Unassigned
            Reporter:
            bodewig Stefan Bodewig
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development