Log4net
  1. Log4net
  2. LOG4NET-284

In a multithreaded application, duplicate messages are output.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.10
    • Fix Version/s: 1.2.12
    • Component/s: Appenders
    • Labels:
      None
    • Environment:
      operating system: Windows Server 2008 R2
      platform : .Net Framework 3.5 (VB.Net)

      Description

      Dear Team,

      We are facing a logging issue in our project. I am looking for help on this.
      We are getting the following messages in the log4net file:

      [INFO ] 2011/1/15 13:51:56,628 (null) 47423855 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 50000 Copied
      [INFO ] 2011/1/15 13:51:57,253 (null) 47430105 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 55000 Copied
      [INFO ] 2011/1/15 13:51:58,362 (null) 47441195 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 60000 Copied
      [INFO ] 2011/1/15 13:51:59,112 (null) 47448695 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 65000 Copied
      [INFO ] 2011/1/15 13:51:59,565 (null) 47453225 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 70000 Copied

       ...

      _CD:5 No:3 Seq:3 FILE_CD:510 50000 Copied
      [INFO ] 2011/1/15 13:51:57,253 (null) 47430105 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 55000 Copied
      [INFO ] 2011/1/15 13:51:58,362 (null) 47441195 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 60000 Copied
      [INFO ] 2011/1/15 13:51:59,112 (null) 47448695 OnSqlRowsCopied
      -HOST_CD:0000 JOB_CD:5 No:3 Seq:3 FILE_CD:510 65000 Copied
      [INFO ] 2011/1/15 13:51:59,565 (null) 47453225 OnSqlRowsCopied
      -HOST_CD:0000 JOB

      They've been printed duplicate some of the messages that were printed earlier.

      Any help is greatly appreciated.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        915d 21h 8m 1 Dominik Psenner 07/Aug/13 13:30
        Dominik Psenner made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Dominik Psenner [ nachbarslumpi ]
        Fix Version/s 1.2.12 [ 12318546 ]
        Fix Version/s 1.2 Maintenance Release [ 12317606 ]
        Resolution Cannot Reproduce [ 5 ]
        Dominik Psenner added a comment -

        Closing the issue because we are unable to reproduce it. Feel free to reopen the issue if still exists for you and help us finding a resolution for it.

        Stefan Bodewig made changes -
        Field Original Value New Value
        Fix Version/s 1.2 Maintenance Release [ 12317606 ]
        S.Kawakami created issue -

          People

          • Assignee:
            Dominik Psenner
            Reporter:
            S.Kawakami
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development