Uploaded image for project: 'Log4net'
  1. Log4net
  2. LOG4NET-257

Visual Studio 2010 .NET 4.0 Application does not copy log4net lib to bin directory

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2.10
    • Fix Version/s: 1.2.11
    • Component/s: Core
    • Labels:
      None
    • Environment:
      Visual Studio 2010 .NET 4.0 project on Windows XP

      Description

      When adding a reference to a .NET 4.0 Console Application in Visual Studio 2010 the IDE does not recognize the library. After downloading the source I was able to get it work by updating all of the references to .NET 4.0 reference. The main one in question is the System.Web reference which I assume is there for the Asp .NET Trace appender.

      Are there plans for updating the library for use with .NET 4.0?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jay.smith Jay Smith
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 24h
                  24h
                  Remaining:
                  Remaining Estimate - 24h
                  24h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified