Log4net
  1. Log4net
  2. LOG4NET-146

System.NullReferenceException on FindAndRender object

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.2.10
    • Fix Version/s: 1.2.11
    • Component/s: Core
    • Labels:
      None
    • Environment:
      Windows 2003 Server Release 2
      Oracle ODP Version (Oracle.DataAccess.dll) 1.102.3.0
      .Net 1.1.4332

      Description

      Get following error text:

      <log4net.Error>Exception rendering object type [System.NullReferenceException]<stackTrace>System.NullReferenceException: Object reference not set to an instance of an object.
      at System.Diagnostics.StackTrace.GetStackFramesInternal(StackFrameHelper sfh, Int32 iSkip, Exception e)
      at System.Diagnostics.StackTrace.CaptureStackTrace(Int32 iSkip, Boolean fNeedFileInfo, Thread targetThread, Exception e)
      at System.Diagnostics.StackTrace..ctor(Exception e, Boolean fNeedFileInfo)
      at System.Environment.GetStackTrace(Exception e)
      at System.Environment.GetStackTrace(Exception e)
      at System.Exception.get_StackTrace()
      at System.Exception.ToString()
      at System.Exception.ToString()
      at log4net.ObjectRenderer.DefaultRenderer.RenderObject(RendererMap rendererMap, Object obj, TextWriter writer)
      at log4net.ObjectRenderer.RendererMap.FindAndRender(Object obj, TextWriter writer)</stackTrace></log4net.Error>

      Exception come form a OracleDataAdapter Fill call from a C# application.

        Activity

        Matthias Krause created issue -
        Ron Grabowski made changes -
        Field Original Value New Value
        Fix Version/s 1.2.11 [ 12310980 ]
        Fix Version/s 1.2.10 [ 11128 ]
        Ron Grabowski added a comment -

        Is this still an issue with the latest version of the Oracle drivers?

        Ron Grabowski added a comment -

        I took a look at DefaultRenderer and it looks like the appropriate null checks are in place. Open another ticket if you, or someone else, can provide more information what was being rendered.

        Ron Grabowski made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Matthias Krause
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development