Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta8
    • Fix Version/s: 2.0-beta9
    • Component/s: Core
    • Labels:
      None

      Description

      As proposed on the mailing list, removing the Generic from Appender will make the API more readable and easier to use. This is an updated patch which does not touch the AbstractDatabase code.

      If you use subversion, just apply the attached patch to trunk. It should apply.

      The easier way to deal with this patch is to do this:

      % mkdir appender-patch
      % cd appender-patch
      % git svn init http://svn.apache.org/repos/asf/logging/log4j/log4j2/trunk
      % git svn fetch -r 1512793
      % git remote add hgschmie https://github.com/hgschmie/logging-log4j2.git
      % git fetch hgschmie
      % git cherry-pick $(git log hgschmie/appender-only | head -1 | cut -d' ' -f2)
      

      which will apply the latest version of the patch automatically to the repo.

      Then doing

      % git svn dcommit 
      

      will put it into subversion.

      1. 0001-convert-Appender-to-not-use-Generics.patch
        271 kB
        Henning Schmiedehausen
      2. LOG4J2-343_20130815-1117+0900.patch
        215 kB
        Remko Popma

        Activity

        Remko Popma added a comment -

        Attached LOG4J2-343_20130815-1117+0900.patch resolves conflicts caused by the LOG4J2-353 refactoring. It also removes the (now unnecessary) @param <T> javadoc comments.

        Remko Popma added a comment -

        Committed in revision 1514231.
        Please verify and close.


          People

          • Assignee:
            Unassigned
            Reporter:
            Henning Schmiedehausen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development