Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-2683

Rename PluginVisitor to more appropriate name

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: Core, Plugins
    • Labels:
      None

      Description

      Given a few more years of experience, after taking a look at PluginVisitor again, I've finally decided it's time to name it more appropriately. This class is following a builder pattern, not a visitor, and it's for injection strategies. Thus, this class can be renamed to something like PluginInjectionBuilder along with some cleanups to make the rest of the parameters that were previously passed to visit() to instead be added as builder properties. The 2.x implementation shims should be updated to use this renamed class as well.

        Attachments

          Activity

            People

            • Assignee:
              mattsicker Matt Sicker
              Reporter:
              mattsicker Matt Sicker
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: