Uploaded image for project: 'Log4j 2'
  1. Log4j 2
  2. LOG4J2-2146

The maven bundle plugin fails due to Java 9

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10.0
    • Fix Version/s: 2.11.0
    • Component/s: API
    • Labels:
      None

      Description

      The Log4j2 API build fails if the clean lifecycle is not specified. This is because of problems in the Maven Bundle Plugin. The latest version of the plugin does not ignore module-info.class and the bnd tool does not ignore classes in META-INF/versions.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ralph.goers@dslextreme.com Ralph Goers
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: