Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta2
    • Fix Version/s: 2.0-beta3
    • Component/s: Layouts
    • Labels:
      None

      Description

      In class org.apache.logging.log4j.core.net.Priority the method getPriority returns a bad priority when used for Syslog messages (the only usage at the moment). The bug is in the statement:

      facility.getCode() << 3 + Severity.getSeverity(level).getCode()

      That's because the operator "+" takes precedence over "<<", and so the facility code isn't shifted by 3 but by "3 + Severity.getSeverity(level).getCode()".

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          9h 39m 1 Ralph Goers 20/Oct/12 01:24
          Resolved Resolved Closed Closed
          2d 7h 36m 1 Emanuele Colombo 22/Oct/12 09:01
          Paul D Johe made changes -
          Link This issue relates to LOG4J2-971 [ LOG4J2-971 ]
          Emanuele Colombo made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Emanuele Colombo added a comment -

          The problem is now solved. Thanks!

          Ralph Goers made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0-beta3 [ 12323368 ]
          Resolution Fixed [ 1 ]
          Ralph Goers added a comment -

          Fix applied in revision 1400349. Please verify then close.

          Emanuele Colombo created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Emanuele Colombo
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development