Uploaded image for project: 'Libcloud'
  1. Libcloud
  2. LIBCLOUD-417

Add Support for Missing Amazon EC2 Elastic IP operations

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.13.2
    • Fix Version/s: 0.14.0-beta3
    • Component/s: Compute
    • Labels:
      None

      Description

      Currently, libcloud does not support for the following operations:

      DisassociateAddress
      ReleaseAddress
      AllocateAddress

      It would be useful to have these features.

      1. LIBCLOUD-417.patch
        1.31 MB
        Patrick Armstrong

        Activity

        oldpatricka Patrick Armstrong added a comment -

        Ah whoops, thanks. Sorry about that.

        kami Tomaz Muraus added a comment -

        Thanks, I've merged patch into trunk but I used the patch generated by Github (https://github.com/apache/libcloud/pull/163.patch) because the patch you have attached is massive.

        I think the problem is that your git fork is vastly out-of-date and not synced with trunk.

        jira-bot ASF subversion and git services added a comment -

        Commit 455f11c9d40ead11d3e4ad7a2f38f4f90b78c866 in branch refs/heads/trunk from Patrick Armstrong
        [ https://git-wip-us.apache.org/repos/asf?p=libcloud.git;h=455f11c ]

        Issue LIBCLOUD-417: Add support for more EC2 Elastic IP Address operations.

        Add support for:

        DisassociateAddress
        ReleaseAddress
        AllocateAddress

        Signed-off-by: Tomaz Muraus <tomaz@apache.org>

        oldpatricka Patrick Armstrong added a comment -

        Patch from pull request here:

        https://github.com/apache/libcloud/pull/163

        oldpatricka Patrick Armstrong added a comment -
        oldpatricka Patrick Armstrong added a comment -

        I have a patch for this available here, in my fork of Libcloud:

        https://github.com/oldpatricka/libcloud/tree/LIBCLOUD-417


          People

          • Assignee:
            Unassigned
            Reporter:
            oldpatricka Patrick Armstrong
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development