Uploaded image for project: 'Libcloud'
  1. Libcloud
  2. LIBCLOUD-310

SoftLayer Driver using incomplete endpoint URL

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.12.1, 0.12.3
    • Fix Version/s: None
    • Component/s: Core
    • Labels:

      Description

      The endpoint URL for the SoftLayer driver is defaulting to localhost (127.0.0.1) for requests using the current "endpoint" as a suffix. It does not prepare the full URL including the actual public-facing API endpoint.

      Adding a base_url seems to resolve the issue.

      Patch available: https://gist.github.com/jasonjohnson/5216077

        Activity

        kami Tomaz Muraus added a comment -

        Thanks.

        I think we have introduced this regression while changing how xmlrpclib stuff works (LIBCLOUD-288).

        I will test your changes later today and if it works correctly merge it into trunk and 0.12.x branch.

        jira-bot ASF subversion and git services added a comment -

        Commit 1460093 from Tomaz Muraus
        [ https://svn.apache.org/r1460093 ]

        Fix a regression in Softlayer driver caused by the xmlrpclib changes. Also
        remove extra trailing slash in the URL path.

        Contributed by Jason Johnson, part of LIBCLOUD-310.

        kami Tomaz Muraus added a comment -

        I've modified your patch to specify host instead of base_url and merged it into trunk and 0.12.x.

        Thanks!


          People

          • Assignee:
            kami Tomaz Muraus
            Reporter:
            spligak Jason Johnson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development