Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Core
    • Labels:

      Description

      I know its an edge case but say when we do update_record() and change the 'type' for the record
      and if it 'is' RecordType.A then the value for it is 0 and in all the dns drivers I see things like 'if type:' which will never be True isn't it ?

      and just fft isn't it a good practice not using keywords like 'type' . Guess we could've used something like record_type or zone_type ? or simply like pep says use 'single_trailing_underscore_:' http://www.python.org/dev/peps/pep-0008/

      I guess we need to set those record type constants starting from 1 in RecordType class.

        Activity

        Hide
        kami Tomaz Muraus added a comment -

        Second issue has also already been fixed in trunk in two days:

        1. We switched to "is not None" check
        2. We switched to ENUM values being string instead of an int

        Show
        kami Tomaz Muraus added a comment - Second issue has also already been fixed in trunk in two days: 1. We switched to "is not None" check 2. We switched to ENUM values being string instead of an int
        Hide
        dineshbhoopathy Dinesh Bhoopathy added a comment -

        @Tomaz : Great! do let me know if I can be of any other help.

        Show
        dineshbhoopathy Dinesh Bhoopathy added a comment - @Tomaz : Great! do let me know if I can be of any other help.
        Hide
        kami Tomaz Muraus added a comment -
        Show
        kami Tomaz Muraus added a comment - First issue fixed in http://svn.apache.org/viewvc?view=revision&revision=r1397769 . Thanks!
        Hide
        kami Tomaz Muraus added a comment -

        Thanks for the report, I agree about both points:

        1. We should rename 'type' to 'record_type'
        2. All the if checks should do 'if record_type is not None' ...

        Show
        kami Tomaz Muraus added a comment - Thanks for the report, I agree about both points: 1. We should rename 'type' to 'record_type' 2. All the if checks should do 'if record_type is not None' ...

          People

          • Assignee:
            kami Tomaz Muraus
            Reporter:
            dineshbhoopathy Dinesh Bhoopathy
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development