Uploaded image for project: 'Libcloud'
  1. Libcloud
  2. LIBCLOUD-242

Various additions to the IBM SBC compute driver

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.1
    • Fix Version/s: 0.10.1
    • Component/s: Compute
    • Labels:
    • Environment:

      Linux

      Description

      Added volume and IP address management

      1. LIBCLOUD-242.patch
        46 kB
        Sengor Kusturica

        Activity

        sengork Sengor Kusturica added a comment -

        Fix confirmed working for all _repr_'s under Python v2.6.6 and v3.2. Thank you.

        kami Tomaz Muraus added a comment -

        Should be fixed in http://svn.apache.org/viewvc?view=revision&revision=1391858.

        Can you please confirm it?

        sengork Sengor Kusturica added a comment -

        Old style string interpolation changes to _repr_ are not working in python 2.6.6 and 3.2. This affects 0.11.3.
        "TypeError: not enough arguments for format string"

        kami Tomaz Muraus added a comment -

        Awesome patch, thanks! I've merged it into trunk with some changes:

        • Changed .format with old style string interpolation since .format doesn't work with Python < 2.6
        • Minor pep8 fixes
        • Make sure 'extra' is always a dictionary
        • Removed trailing whitespace
        • Removed print statement
        sengork Sengor Kusturica added a comment -

        the patch


          People

          • Assignee:
            kami Tomaz Muraus
            Reporter:
            sengork Sengor Kusturica
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 24h
              24h
              Remaining:
              Remaining Estimate - 24h
              24h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development