Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.10.1
    • Fix Version/s: 0.11.0
    • Component/s: Storage
    • Labels:
    • Environment:

      OS X 10.7.4, Python 2.7.1

      Description

      For Rackspace Cloudfiles, container.get_cdn_url() fails. It's hitting https://storage101.dfw1.clouddrive.com:443 when it should be doing a request to https://cdn1.clouddrive.com:443.

      container.get_cdn_url()
      File "/Users/ggreer/code/libcloud/libcloud/storage/base.py", line 123, in get_cdn_url
      return self.driver.get_container_cdn_url(container=self)
      File "/Users/ggreer/code/libcloud/libcloud/storage/drivers/cloudfiles.py", line 276, in get_container_cdn_url
      cdn_url = response.headers['x-cdn-uri']
      KeyError: 'x-cdn-uri'

      The problem is that Connection::request() calls morph_action_hook, which calls _populate_hosts_and_request_paths(), which changes self.host. This happens after CloudFilesConnection::request calls _reset_connection_params().

        Activity

        angryparsley Geoff Greer added a comment -

        This fixes a big hack with a slightly smaller hack.

        kami Tomaz Muraus added a comment -

        Merged, thanks.


          People

          • Assignee:
            Unassigned
            Reporter:
            angryparsley Geoff Greer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development