Uploaded image for project: 'Apache Lens'
  1. Apache Lens
  2. LENS-1472

Populate sample metastore on example db is failing

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8
    • Component/s: examples
    • Labels:
      None

      Description

      Error Message: Internal Server Error.: MetaException(message:file:/usr/local/lens/client/examples/data/sales_aggr_fact2_local4 is not a directory or unable to create one)
      	at org.apache.lens.client.LensMetadataClient.translate(LensMetadataClient.java:73)
      	at org.apache.lens.client.LensMetadataClient.addPartitionsToFactTable(LensMetadataClient.java:875)
      	at org.apache.lens.examples.PopulateSampleMetastore.createFactPartitions(PopulateSampleMetastore.java:172)
      	at org.apache.lens.examples.PopulateSampleMetastore.populateFactTables(PopulateSampleMetastore.java:196)
      	at org.apache.lens.examples.PopulateSampleMetastore.populateAll(PopulateSampleMetastore.java:84)
      	at org.apache.lens.examples.PopulateSampleMetastore.main(PopulateSampleMetastore.java:71)
      
      1. LENS-1472.01.patch
        2 kB
        Rajat Khandelwal
      2. LENS-1472.02.patch
        4 kB
        Rajat Khandelwal

        Activity

        prongs Rajat Khandelwal added a comment -
        prongs Rajat Khandelwal added a comment -

        Taking patch from reviewboard and attaching

        archana.h Archana H added a comment -

        One more error in the same

        Exception in thread "main" java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: MYDB_SALES_AGGR_CONTINUOUS_FACT
        	at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
        	at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
        	at org.hsqldb.jdbc.JDBCStatement.fetchResult(Unknown Source)
        	at org.hsqldb.jdbc.JDBCStatement.execute(Unknown Source)
        	at org.apache.lens.examples.PopulateSampleMetastore.createContinuousFactData(PopulateSampleMetastore.java:122)
        	at org.apache.lens.examples.PopulateSampleMetastore.populateFactTables(PopulateSampleMetastore.java:199)
        	at org.apache.lens.examples.PopulateSampleMetastore.populateAll(PopulateSampleMetastore.java:84)
        	at org.apache.lens.examples.PopulateSampleMetastore.main(PopulateSampleMetastore.java:71)
        Caused by: org.hsqldb.HsqlException: user lacks privilege or object not found: MYDB_SALES_AGGR_CONTINUOUS_FACT
        	at org.hsqldb.error.Error.error(Unknown Source)
        	at org.hsqldb.error.Error.error(Unknown Source)
        	at org.hsqldb.SchemaManager.getTable(Unknown Source)
        	at org.hsqldb.ParserDQL.readTableName(Unknown Source)
        	at org.hsqldb.ParserDQL.readRangeVariableForDataChange(Unknown Source)
        	at org.hsqldb.ParserDML.compileInsertStatement(Unknown Source)
        	at org.hsqldb.ParserCommand.compilePart(Unknown Source)
        	at org.hsqldb.ParserCommand.compileStatements(Unknown Source)
        	at org.hsqldb.Session.executeDirectStatement(Unknown Source)
        	at org.hsqldb.Session.execute(Unknown Source)
        
        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1472.01.patch and ran command: mvn clean install -fae. Result: Failure. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1431/

        prongs Rajat Khandelwal added a comment -

        Taking patch from reviewboard and attaching

        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1472.02.patch and ran command: mvn clean install -fae. Result: Failure. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1432/

        prongs Rajat Khandelwal added a comment -

        Committed myself.

        hudson Hudson added a comment -

        UNSTABLE: Integrated in Jenkins build Lens-Commit #1440 (See https://builds.apache.org/job/Lens-Commit/1440/)
        LENS-1472: Populate sample metastore on example db is failing (rajatgupta59: rev 2b86ac2b83608efb957777d9c89c10445c4a30f5)

        • (edit) lens-examples/src/main/java/org/apache/lens/examples/PopulateSampleMetastore.java
        • (edit) lens-examples/src/main/java/org/apache/lens/examples/SampleMetastore.java
        • (add) lens-examples/src/main/resources/sales-aggr-fact2-local4.data
        • (edit) lens-dist/src/main/assembly/bin-dist.xml

          People

          • Assignee:
            prongs Rajat Khandelwal
            Reporter:
            prongs Rajat Khandelwal
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development