Uploaded image for project: 'Apache Lens'
  1. Apache Lens
  2. LENS-1439

Having clause getting skipped if query goes to a segmentation containing single segment

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.7, 2.8
    • Component/s: cube
    • Labels:
      None

      Description

      The condition of setHaving(null) is wrong in singleCandidatehqlcontext

      1. LENS-1439.01.patch
        2 kB
        Rajat Khandelwal
      2. LENS-1439.01.patch
        0.8 kB
        Rajat Khandelwal
      3. LENS-1439.02.patch
        3 kB
        Rajat Khandelwal

        Activity

        prongs Rajat Khandelwal added a comment -
        prongs Rajat Khandelwal added a comment -

        Taking patch from reviewboard and attaching

        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1439.01.patch and ran command: mvn clean install -fae. Result: Failure. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1334/

        prongs Rajat Khandelwal added a comment -

        Committed myself.

        hudson Hudson added a comment -

        UNSTABLE: Integrated in Jenkins build Lens-Commit #1415 (See https://builds.apache.org/job/Lens-Commit/1415/)
        LENS-1439: Having clause getting skipped if query goes to a segmentation (rajatgupta59: rev 2f56c741bffea20678007eff4e0173bb6dc06110)

        • (edit) lens-cube/src/main/java/org/apache/lens/cube/parse/StorageCandidateHQLContext.java
        prongs Rajat Khandelwal added a comment -

        Reopening as the issue is not fixed.

        prongs Rajat Khandelwal added a comment -
        prongs Rajat Khandelwal added a comment -

        Taking patch from reviewboard and attaching

        amareshwari Amareshwari Sriramadasu added a comment -

        Rajat Khandelwal Can we add unit test?

        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1439.01.patch and ran command: mvn clean install -fae. Result: Success. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1381/

        prongs Rajat Khandelwal added a comment -

        Taking patch from reviewboard and attaching

        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1439.02.patch and ran command: mvn clean install -fae. Result: Failure. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1383/

        prongs Rajat Khandelwal added a comment -

        Amareshwari Sriramadasu Added in latest patch.

        hadoopqa Hadoop QA added a comment -

        Applied patch: LENS-1439.02.patch and ran command: mvn clean install -fae. Result: Success. Build Job: https://builds.apache.org/job/PreCommit-Lens-Build/1384/

        prongs Rajat Khandelwal added a comment -

        Committed myself.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Lens-Commit #1438 (See https://builds.apache.org/job/Lens-Commit/1438/)
        LENS-1439: Having clause getting skipped if query goes to a segmentation (rajatgupta59: rev a8d23df80dcfc22b3d67938f8f522bbd33072466)

        • (edit) lens-cube/src/test/resources/schema/cubes/derived/union_join_ctx_der1.xml
        • (edit) lens-cube/src/test/java/org/apache/lens/cube/parse/TestCubeSegmentationRewriter.java
        • (edit) lens-cube/src/main/java/org/apache/lens/cube/parse/StorageCandidateHQLContext.java

          People

          • Assignee:
            prongs Rajat Khandelwal
            Reporter:
            prongs Rajat Khandelwal
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development