Commons Lang
  1. Commons Lang
  2. LANG-21

[lang] escapeXML() -> Not escaping low characters

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Other

      Description

      Low characters such as #18 are not escaped, and therefore are mixed together
      with other characteres as if there were normal characteres such as 'a', '1' etc.

      Possibly solved in other versions?

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Reopened Reopened Resolved Resolved
        66d 7h 42m 1 Henri Yandell 06/Jun/06 03:59
        Resolved Resolved Closed Closed
        245d 20h 47m 1 Henri Yandell 06/Feb/07 23:47
        Mark Thomas made changes -
        Workflow jira [ 12371908 ] Default workflow, editable Closed status [ 12602154 ]
        Henri Yandell made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Henri Yandell made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Henri Yandell added a comment -

        We have two reports currently, one that we don't escape low characters and should do; and one that we do escape high characters and shouldn't do.

        I'm marking this as WONTFIX based on Phil's thoughts on the commons-user mailing list. It's easier to add the code to escape than it would be to undo it.

        The escaping high characters issue will be fixed to not escape.

        Henri Yandell made changes -
        Fix Version/s 2.2 [ 12311702 ]
        Henri Yandell made changes -
        Affects Version/s 2.1 Final [ 12311701 ]
        Henri Yandell made changes -
        Affects Version/s 2.1 Final [ 12311659 ]
        Component/s Lang [ 12311121 ]
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Project Commons [ 12310458 ] Commons Lang [ 12310481 ]
        Fix Version/s 2.2 [ 12311686 ]
        Key COM-2851 LANG-21
        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 39167 12343003
        Henri Yandell added a comment -

        There's been discussion on this on the user mailing list.

        Henri Yandell added a comment -

        Oops, not a dupe. It's at the opposite end of the spectrum.

        Henri Yandell added a comment -
            • This bug has been marked as a duplicate of 38210 ***
        David López created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            David López
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development