Commons Lang
  1. Commons Lang
  2. LANG-189

[lang] Add method that validates Collection elements are a certain type

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Attached is a patch that adds a new method to Validate that validates that a
      Collection only contains elements of a certain type.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Closed Closed Reopened Reopened
        879d 13h 50m 1 Henri Yandell 20/May/06 00:59
        Reopened Reopened Closed Closed
        36s 1 Henri Yandell 20/May/06 00:59
        Mark Thomas made changes -
        Workflow jira [ 12370074 ] Default workflow, editable Closed status [ 12602087 ]
        Henri Yandell made changes -
        Resolution Fixed [ 1 ]
        Status Reopened [ 4 ] Closed [ 6 ]
        Henri Yandell added a comment -

        Reopening then closing to deal with migration bug.

        Henri Yandell made changes -
        Status Closed [ 6 ] Reopened [ 4 ]
        Henri Yandell added a comment -

        Reopening then closing to deal with migration bug.

        Henri Yandell made changes -
        Fix Version/s 2.1 Final [ 12311701 ]
        Henri Yandell made changes -
        Affects Version/s 2.0 Final [ 12311706 ]
        Henri Yandell made changes -
        Component/s Lang [ 12311121 ]
        Affects Version/s 2.0 Final [ 12311658 ]
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Project Commons [ 12310458 ] Commons Lang [ 12310481 ]
        Fix Version/s 2.1 Final [ 12311659 ]
        Key COM-1018 LANG-189
        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 25683 12341169
        Henri Yandell added a comment -

        2.1 released, closing.

        Stephen Colebourne added a comment -

        Patch applied, thanks

        David Graham added a comment -

        Changed summary to include [lang] so it wouldn't be confused with [validator] in
        email subject lines.

        Norm Deane added a comment -
            • COM-1019 has been marked as a duplicate of this bug. ***
        Norm Deane added a comment -

        Created an attachment (id=9657)
        New Validate methods

        Norm Deane created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Norm Deane
          • Votes:
            2 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development