Commons Lang
  1. Commons Lang
  2. LANG-152

[lang] DurationFormatUtils.formatDurationWords "11 <unit>s" gets converted to "11 <unit>"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: Other

      Description

      The method DurationFormatUtils.formatDurationWords incorrectly outputs numbers
      ending in "1" without a plural "s" postfix for the time unit.

      Added a fix and tests that "1 <unit>s" gets converted to "1 <unit>" but that "11
      <unit>s" is left alone.

        Activity

        ggregory@seagullsw.com created issue -
        ggregory@seagullsw.com added a comment -

        Target Milestone: 2.2.

        Henri Yandell added a comment -
            • COM-2382 has been marked as a duplicate of this bug. ***
        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 37596 12342730
        Henri Yandell made changes -
        Key COM-2578 LANG-152
        Project Commons [ 12310458 ] Commons Lang [ 12310481 ]
        Fix Version/s 2.2 [ 12311686 ]
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Component/s Lang [ 12311121 ]
        Affects Version/s Nightly Builds [ 12311648 ]
        Henri Yandell made changes -
        Affects Version/s Nightly Builds [ 12311718 ]
        Henri Yandell made changes -
        Fix Version/s 2.2 [ 12311702 ]
        Henri Yandell made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Workflow jira [ 12371635 ] Default workflow, editable Closed status [ 12602191 ]
        Mark Thomas made changes -
        Reporter Gary Gregory [ ggregory@seagullsw.com ] Gary D. Gregory [ garydgregory ]
        Henri Yandell made changes -
        Affects Version/s Nightly Builds [ 12311718 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Gary Gregory
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development