Uploaded image for project: 'Apache Knox'
  1. Apache Knox
  2. KNOX-2073

Overlapping dependencies - commons bean utils 1.9.x vs 1.8.x

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None

      Description

      As part of the commons bean utils upgrade (to 1.9.4) some class are overlaps with the  commons-beanutils-core 1.8.0 (transitive dependency of commons-configuration).

       

      Based on the BeanUtils doc there is no 3 jar separation from 1.9.0:
      http://commons.apache.org/proper/commons-beanutils/#BeanUtils_Core_And_Modules

       

      I think commons-beanutils-core 1.8.0 should be excluded

        Attachments

        1. KNOX-2073.patch
          2 kB
          Kalman

          Issue Links

            Activity

              People

              • Assignee:
                Jantner Kalman
                Reporter:
                Jantner Kalman
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: