Karaf
  1. Karaf
  2. KARAF-651

features-maven-plugin should "embed" the Karaf features descriptor

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.2, 3.0.0
    • Component/s: karaf-tooling
    • Labels:
      None

      Description

      To be compatible with several Karaf versions, projects (such as Camel or CXF) should remove:

      <repositories>mvn:org.apache.karaf.assemblies.features/standard/2.2.0/xml/features</repositories>

      It's an expected behavior as the Karaf features are available by default in the Karaf runtime. Only "external" features descriptor should be defined in <repositories/> section.

      It means that the features-maven-plugin should "embed" the Karaf features descriptor and use it be default.

        Activity

        Jean-Baptiste Onofré added a comment -

        I defined a features descriptor which looks like:

        <?xml version="1.0" encoding="UTF-8"?>
        <features>

        <feature name="my" version="1.0">
        <feature>http</feature>
        <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.dbunit/2.2_1-SNAPSHOT</bundle>
        </feature>

        </features>

        The validation works fine using karaf-maven-plugin 3.0.0-SNAPSHOT but fails using Karaf 2.2.1 features-maven-plugin.

        So the issue is local to karaf-2.2.x branch.

        Jean-Baptiste Onofré added a comment -

        This issue is hidden on 3.0.0-SNAPSHOT with Aether protocol usage but it still presents. I will apply the fix there also.

        Jean-Baptiste Onofré added a comment -

        Committing to https://svn.apache.org/repos/asf/karaf/branches/karaf-2.2.x ...
        M manual/src/main/webapp/developers-guide/features-maven-plugin-validate.conf
        M tooling/features-maven-plugin/src/main/java/org/apache/karaf/tooling/features/ValidateFeaturesMojo.java
        Committed r1129620

        Jean-Baptiste Onofré added a comment -

        Committing to https://svn.apache.org/repos/asf/karaf/trunk ...
        R manual/src/main/webapp/developers-guide/features-maven-plugin-add.conf => manual/src/main/webapp/developers-guide/karaf-maven-plugin-add.conf
        R manual/src/main/webapp/developers-guide/features-maven-plugin-generate.conf => manual/src/main/webapp/developers-guide/karaf-maven-plugin-generate.conf
        R manual/src/main/webapp/developers-guide/features-maven-plugin-validate.conf => manual/src/main/webapp/developers-guide/karaf-maven-plugin-validate.conf
        D manual/src/main/webapp/developers-guide/features-maven-plugin.conf
        M manual/src/main/webapp/developers-guide/index.conf
        A manual/src/main/webapp/developers-guide/karaf-maven-plugin.conf
        M tooling/karaf-maven-plugin/src/main/java/org/apache/karaf/tooling/features/ValidateFeaturesMojo.java
        Committed r1129650

        Jamie goodyear added a comment -

        Fixed in Apache Karaf 2.2.2.


          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development