Karaf
  1. Karaf
  2. KARAF-648

maven-enforcer-plugin configuration not used

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.2
    • Component/s: None
    • Labels:
      None

      Description

      The maven-enforcer-plugin configuration defined in Karaf trunk and karaf-2.2.x branch doesn't seem to be used.

      I'm able to build karaf-2.2.x using maven 3.0.3 and JDK 1.5 which is not the configuration defined.

      More over, the karaf-2.2.x configuration is not correct as this branch should support JDK 1.5.

        Activity

        Hide
        Jamie goodyear added a comment -

        Fixed in Apache Karaf 2.2.2.

        Show
        Jamie goodyear added a comment - Fixed in Apache Karaf 2.2.2.
        Hide
        Jean-Baptiste Onofré added a comment -

        Already done on trunk.

        Fixed on karaf-2.2.x branch: revision 1124562.

        Show
        Jean-Baptiste Onofré added a comment - Already done on trunk. Fixed on karaf-2.2.x branch: revision 1124562.
        Hide
        Jean-Baptiste Onofré added a comment -

        The maven-enforcer-plugin is defined in the release profile.

        It should be "global".

        Show
        Jean-Baptiste Onofré added a comment - The maven-enforcer-plugin is defined in the release profile. It should be "global".

          People

          • Assignee:
            Jean-Baptiste Onofré
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development