Karaf
  1. Karaf
  2. KARAF-610

Can't input the path string completely via karaf shell

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.6, 3.0.0
    • Component/s: karaf-shell
    • Labels:
      None
    • Environment:

      JRE 1.6.0 IBM J9 2.4 Windows XP x86-32

      Description

      1. Use Karaf 2.2.0
      2. Start the server by running the command: bin\karaf.bat
      3. Install a bundle via karaf shell and try to input :install <filePath>
      4. Found the karaf shell console only allow input one line and you can't input anything for another line.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          16m 58s 1 Freeman Fang 05/May/11 07:31
          Resolved Resolved Reopened Reopened
          11d 20h 36m 1 Tina Li 17/May/11 04:07
          Reopened Reopened Resolved Resolved
          216d 13h 13m 1 Christian Schneider 19/Dec/11 16:21
          Resolved Resolved Closed Closed
          130d 6h 44m 1 Jamie goodyear 28/Apr/12 00:05
          Gavin made changes -
          Link This issue is depended upon by GERONIMO-5948 [ GERONIMO-5948 ]
          Gavin made changes -
          Link This issue blocks GERONIMO-5948 [ GERONIMO-5948 ]
          Jamie goodyear made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Christian Schneider made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Christian Schneider added a comment -

          The issue is still present in Karaf 2.2.4

          Christian Schneider added a comment -

          At least after my fix for https://issues.apache.org/jira/browse/KARAF-1071 long inputs seem to work on windows with karaf 3.0.0-SNAPSHOT. Will test with Karaf 2.x

          Christian Schneider made changes -
          Assignee Jean-Baptiste Onofré [ jbonofre ] Christian Schneider [ chris@die-schneider.net ]
          Jean-Baptiste Onofré made changes -
          Fix Version/s 2.2.6 [ 12319142 ]
          Fix Version/s 2.2.5 [ 12317857 ]
          Jean-Baptiste Onofré made changes -
          Fix Version/s 2.2.5 [ 12317857 ]
          Fix Version/s 3.1.0 [ 12316946 ]
          Fix Version/s 2.2.4 [ 12317342 ]
          Jean-Baptiste Onofré added a comment -

          Same comment as in KARAF-479.

          Jean-Baptiste Onofré made changes -
          Fix Version/s 2.2.4 [ 12317342 ]
          Fix Version/s 2.2.3 [ 12316685 ]
          Jean-Baptiste Onofré made changes -
          Fix Version/s 3.1.0 [ 12316946 ]
          Jean-Baptiste Onofré made changes -
          Fix Version/s 2.2.3 [ 12316685 ]
          Fix Version/s 2.2.1 [ 12316164 ]
          Bruce Bolingbroke added a comment -

          I agree with Achim. This is a duplicate of KARAF-479. Please make this a high priority for 2.2.2.

          Achim Nierbeck added a comment -

          Same issue as with KARAF-479

          Achim Nierbeck made changes -
          Link This issue is duplicated by KARAF-479 [ KARAF-479 ]
          Tina Li made changes -
          Attachment karaf-610.JPG [ 12479429 ]
          Tina Li added a comment -

          Can't input anything for the second line.

          Tina Li made changes -
          Resolution Duplicate [ 3 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Tina Li added a comment - - edited

          Hi, I downloaded the latest release of Karaf 2.2.1.
          Tried again on windows xp x86-32, still find the same problem.
          The picture karaf-610.jpg is attached for detail.
          Please have a check, thanks.

          Jean-Baptiste Onofré added a comment -

          I confirmed that it has been fixed on karaf-2.2.x branch also (revision 1087203). So it will be included in the next Karaf 2.2.1 release.

          Freeman Fang made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.2.1 [ 12316164 ]
          Fix Version/s 3.0.0 [ 12316040 ]
          Resolution Duplicate [ 3 ]
          Freeman Fang made changes -
          Link This issue duplicates KARAF-542 [ KARAF-542 ]
          Freeman Fang added a comment -

          Hi,

          I believe Guillaume already fix this issue through KARAF-542.

          Freeman

          Jean-Baptiste Onofré made changes -
          Assignee Jean-Baptiste Onofré [ jbonofre ]
          Jean-Baptiste Onofré added a comment -

          It's fixed on Karaf trunk (3.0.0), using > character to complete long line.

          Let me check if I can merge that to 2.2.1.

          Tina Li made changes -
          Field Original Value New Value
          Link This issue blocks GERONIMO-5948 [ GERONIMO-5948 ]
          Tina Li created issue -

            People

            • Assignee:
              Christian Schneider
              Reporter:
              Tina Li
            • Votes:
              3 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development